Scrapy安装错误:Microsoft Visual C++ 14.0 is required

技术探讨  2018-02-07 14:21   4271 scrapy pyhon Microsoft Visual C++

scrapy1.5安装过程中 运行 : pip install scrapy  出现错误:Microsoft Visual C++ 14.0 is required. 如下:

当前环境win10, Python 3.6.4 (v3.6.4:d48eceb, Dec 19 2017, 06:54:40) [MSC v.1900 64 bit (AMD64)] on win32。 
在windows下,在dos中运行pip install Scrapy报错:

TIM截图20180207141316.png


解决方案

http://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted 下载twisted对应版本的whl文件(如我的Twisted-17.9.0-cp36-cp36m-win_amd64.whl),cp后面是python版本,amd64代表64位,运行命令:

 pip install C:\Users\feoyo\PycharmProjects\Twisted-17.9.0-cp36-cp36m-win_amd64.whl

其中install后面为下载的whl文件的完整路径名 
安装完成后,再次运行:

pip install Scrapy1

即可成功。

blob.png

注:转载请注明出处为http://www.sandbean.com/article/47.html。

沙豆网 站长

自己选择的远方,爬着也要走完...

141
文章
6532
点赞

更多文章